当前位置: 代码迷 >> 综合 >> ZZULI_SUMMER_PRACTICE(7)nbsp;1171
  详细解决方案

ZZULI_SUMMER_PRACTICE(7)nbsp;1171

热度:65   发布时间:2024-01-04 11:01:31.0
Problem B

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 74   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1
Sample Output
20 10
40 40
挺好的一道题,完全背包问题,做题时竟然想不起来完全背包的英文怎么写了,唉,浪费了好长时间……
代码:
#include<stdio.h>
#include<string.h>
int map[130000],V;
void ZeroOnePack(int weight,int cost)
{
int i;
for(i=V;i>=weight;i--)
if(map[i]<map[i-weight]+cost)
map[i]=map[i-weight]+cost;
}
void CompletePack(int weight,int cost)
{
int i;
for(i=weight;i<=V;i++)
if(map[i]<map[i-weight]+cost)
map[i]=map[i-weight]+cost;
}
void MiulipletePack(int weight,int cost,int amount)
{
int k;
if(amount*weight>=V)
CompletePack(weight,cost);
k=1;
while(amount>k){
ZeroOnePack(weight*k,cost*k);
amount-=k;
k*=2;
}
ZeroOnePack(weight*amount,cost*amount);
}
int main()
{
int n,weight[55],number[55],i,sum;
while(scanf("%d",&n),n>=0)
{
memset(map,0,sizeof(map));
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%d",&weight[i],&number[i]);
sum+=weight[i]*number[i];
}
V=sum/2;
for(i=1;i<=n;i++)
MiulipletePack(weight[i],weight[i],number[i]);
printf("%d %d\n",sum-map[V],map[V]);
}
return 0;
}
  相关解决方案