当前位置: 代码迷 >> 综合 >> 杭电oj1014:Uniform Generator
  详细解决方案

杭电oj1014:Uniform Generator

热度:23   发布时间:2023-12-28 08:10:43.0

Uniform Generator

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output

     3         5    Good Choice15        20    Bad Choice63923     99999    Good Choice
#include<iostream>
#include<cstring>
using namespace std;int arr[100005];int main()
{
    //freopen("in.txt","r",stdin);int step, mod;while(scanf("%d%d",&step, &mod)!=EOF){
    memset(arr,0,sizeof(arr));int seedx=0, counts=0;arr[seedx] = 1;string str = "Bad Choice";while(1){
    seedx = (seedx+step)%mod;counts++;if(arr[seedx]==1)break;arr[seedx]=1;}if(counts==mod)str = "Good Choice";printf("%10d%10d %s\n\n",step, mod, &str[0]);}return 0;
}

改进之后:不需要数组来存储

#include<iostream>
#include<cstring>
using namespace std;
//不需要数组来存储 
int main()
{
    //freopen("in.txt","r",stdin);int step, mod;while(scanf("%d%d",&step, &mod)!=EOF){
    int seedx=0, counts=0;string str = "Bad Choice";do{
    seedx = (seedx+step)%mod;counts++;}while(seedx!=0);//因为从0开始,所以如果等于0说明循环了 if(counts==mod)str = "Good Choice";printf("%10d%10d %s\n\n",step, mod, &str[0]);}return 0;
}
  相关解决方案