1060 Are They Equal (25分)
Problem Description
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10?^5 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^?100, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
#include<iostream>
using namespace std;/* 思路: 如果有前导0,删除前导0,例如:00123===>123 小数点后如果有0,删除小数点后的0,如:0.0012===>.12 */
int n;string deal(string str, int &e1)
{
//删除前导0 while(str.length() > 0 && str[0]=='0'){
str.erase(str.begin());}if(str.length() == 0) //str类似为0.0000 e1 = 0;else if(str[0] == '.'){
str.erase(str.begin());//删除小数点 //删除小数点后的0 while(str.length() > 0 && str[0]=='0'){
str.erase(str.begin());e1--;}if(str.length() == 0) //str类似为0.0000 e1 = 0;}else{
//寻找小数点 while(e1 < str.length() && str[e1] != '.'){
e1++;}//删除小数点 if(str[e1] == '.')str.erase(e1, 1);}//预处理完成string temp = "";if(str.length() >= n)//如果str的长度大于n,则直接可以赋值给temp temp = str.substr(0, n);else{
temp = str;//如果str的长度小于n,则需要后补0 for(int i=str.length();i<n;i++)temp += "0";}return temp;
}int main()
{
string a, b;cin>>n>>a>>b;int e1 = 0, e2 = 0;//指数 string s1 = deal(a, e1);string s2 = deal(b, e2);if(s1 == s2 && e1 == e2) //主体相同且指数相同 cout<<"YES 0."<<s1<<"*10^"<<e1<<endl;elsecout<<"NO 0."<<s1<<"*10^"<<e1<<" 0."<<s2<<"*10^"<<e2<<endl;return 0;
}