数独是一种传统益智游戏,你需要把一个 9×9 的数独补充完整,使得图中每行、每列、每个 3×3 的九宫格内数字 1?9 均恰好出现一次。
请编写一个程序填写数独。
输入格式
输入共 9 行,每行包含一个长度为 9 的字符串,用来表示数独矩阵。
其中的每个字符都是 1?9 或 .(表示尚未填充)。
输出格式
输出补全后的数独矩阵。
数据保证有唯一解。
输入样例:
.2738…1.
.1…6735
…29
3.5692.8.
…
.6.1745.3
64…
9518…7.
.8…6534.
输出样例:
527389416
819426735
436751829
375692184
194538267
268174593
643217958
951843672
782965341
用col row 分别判断每行每列是否有数已存在,jg判读九宫格
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
const int N=1e3+5;
typedef long long ll;
char g[12][12];
int col[12][12],row[12][12],jg[12][12][12],flag;
int dfs(int x,int y)
{
if(y==9) x++,y=0;if(x==9){
for(int i=0; i<9; i++)printf("%s\n",g[i]);return 1;}if(g[x][y]!='.') return dfs(x,y+1);for(int i=1; i<10; i++){
if(!col[x][i]&&!row[y][i]&&!jg[x/3][y/3][i]){
g[x][y]=i+'0';col[x][i]=row[y][i]=jg[x/3][y/3][i]=1;if(dfs(x,y+1)) return 1;g[x][y]='.';col[x][i]=row[y][i]=jg[x/3][y/3][i]=0;}}return 0;
}
int main()
{
int i,j;for(i=0; i<9; i++)scanf("%s",g[i]);for(i=0; i<9; i++){
for(j=0; j<9; j++){
if(g[i][j]!='.'){
int t=g[i][j]-'0';col[i][t]=row[j][t]=jg[i/3][j/3][t]=1;}}}dfs(0,0);return 0;
}