题目链接
Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2…M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题目大意:
现有n个农场,这n个农场中的牛要去x农场聚会。每个农场中的牛去和返回都要走最短路,问总耗时最长的牛所耗时间是多少。
解题思路:
首先就想到了Floyd算法,写完之后果然超时了。。。
我们可以先求出从x到其余各个农场的最短路径,代表它们返回的最短路径;然后将所有边反向,再求从x到 i 的最短路径代表它们来参加聚会的最短路径,这样对应相加找出一个最大值就可以了。总共使用了两次dijkstra算法。
AC代码:
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn 10001
int map[maxn][maxn];//存放地图信息
int d[maxn];
int data2[maxn];//存放第一次使用dijkstra算法之后的返回最短路径
bool mark[maxn];
int n, m, x;
#define INF 0x3fffffff
void init() {
//初始化for (int i = 1; i <= n; i++) {
for (int j = 1; j <= n; j++) {
map[i][j] = -1;}map[i][i] = 0;d[i] = INF; mark[i] = false;}
}
void rev() {
//矩阵转置int tmp;for (int i = 1; i <= n; i++) {
for (int j =i+1; j <= n; j++) {
tmp = map[i][j]; map[i][j] = map[j][i];map[j][i] = tmp;}}
}
void dj(int s) {
//单源最短路径 s是起点for (int i = 1; i <= n; i++) {
d[i] = INF; mark[i] = false;}d[s] = 0; mark[s] = true;int newnode = s;for (int k = 1; k < n; k++) {
//循环n-1次for (int j = 1; j <= n; j++) {
if (mark[j] || map[newnode][j] == -1) continue;if (d[j] == INF || d[j] > d[newnode] + map[newnode][j]) {
d[j] = d[newnode] + map[newnode][j];}}int tmp = INF;for (int i = 1; i <= n; i++) {
if (mark[i] || d[i] == INF) continue;if (d[i] < tmp) {
tmp = d[i]; newnode = i;}}mark[newnode] = true;}
}
int main() {
scanf("%d%d%d", &n, &m, &x);init();int u, v, w;for (int i = 1; i <= m; i++) {
scanf("%d%d%d", &u, &v, &w);map[u][v] = w;}dj(x);//求出从终点向其他结点的花费for (int i = 1; i <= n; i++) {
data2[i] = d[i]; }rev();dj(x);int ans = 0;for (int j = 1; j <= n; j++) {
ans = max(ans, data2[j] + d[j]);}printf("%d\n", ans);
}