Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2
1 2
3 6
Sample Output
1
3
#include <iostream>
__int64 Fab(int n)
{
__int64 f1 = 1, f2 = 1, f3 = 0;
if(1 == n || 2 == n)
{
return 1;
}
else
{
for(int i = 1;i < n;++ i)
{
f3 = f1 + f2;
f1 = f2;
f2 = f3;
}
return f3;
}
}
int main(int argc, const char *argv[])
{
int n;
while(std::cin >> n)
{
while(n --)
{
int a, b;
std::cin >> a >> b;
std::cout << Fab(b - a) << std::endl;
}
}
//system("pause");
return 0;
}