Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element
in the ith row and jth column should be the product(乘积) of i and j.
Input
The first line of input is an integer C which indicate the number of test cases.
Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which
mentioned above.
Output
For each test case, print out the multiply table.
Sample Input
2
1
4
Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16
Hint
There is no blank space at the end of each line.
#include <cstdio>
int main(int argc, const char* argv[])
{
int nCases = 0;
scanf("%d", &nCases);
while (nCases--)
{
int n = 0;
scanf("%d", &n);
for (int i=1; i<=n; ++i)
{
for (int j=1; j<=n; ++j)
{
if (j == n)
{
printf("%d", i*j);
}
else
{
printf("%d ", i*j);
}
}
printf("\n");
}
}
return 0;
}