当前位置: 代码迷 >> 综合 >> hdoj Max Factor
  详细解决方案

hdoj Max Factor

热度:74   发布时间:2023-12-17 09:17:10.0

Max Factor

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 9
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38
 
  
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define maxn 30000
using namespace std;
int  isprime[maxn];
void   countprime(){
int i,j;
for(i=2;i*i<maxn;++i){
if(isprime[i])continue;
for(j=i*i;j<maxn;j+=i)
isprime[j]=1;}
}
int main()
{
countprime();
int a,n,k,i,j,max;
while(scanf("%d",&k)!=EOF){
max=0;
while(k--){
scanf("%d",&n);
for(i=n;i>=0;--i){
if((n%i==0)&&(isprime[i]!=1))break;
}
if(i>max){
max=i;a=n;}
}
printf("%d\n",a);
}
return 0;
}