当前位置: 代码迷 >> 综合 >> hdoj Elevator
  详细解决方案

hdoj Elevator

热度:6   发布时间:2023-12-17 09:16:40.0

Elevator

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 31   Accepted Submission(s) : 26
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41
 
  
 
  
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int main()
{
int f,a[110],n,i,k,s;
while(scanf("%d",&n),n){
memset(a,0,sizeof(a));
for(i=1;i<=n;++i)
scanf("%d",&a[i]);
a[0]=0;s=0;
for(i=1;i<=n;++i){
f=a[i]-a[i-1];
if(f>0)
s=s+f*6+5;
else 
s=s+abs(f)*4+5;}
printf("%d\n",s);}
return 0;
}