Language:
Cow Sorting
Description Farmer John's N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ's milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y. Please help FJ calculate the minimal time required to reorder the cows. Input
Line 1: A single integer:
N.
Lines 2.. N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i. Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input 3 2 3 1 Sample Output 7 Hint
2 3 1 : Initial order.
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3). Source
USACO 2007 February Gold
|
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=10010;
struct Node{int num,pos;
}A[maxn];
int array[maxn];
bool cmp(Node a,Node b){return a.num<b.num;
}
int main()
{int n,i,j,k;while(scanf("%d",&n)!=EOF){int minn=inf,ans=0;for(i=0;i<n;++i){scanf("%d",&array[i]);minn=min(minn,array[i]);A[i].num=array[i];A[i].pos=i;ans+=array[i];}sort(A,A+n,cmp);for(i=0;i<n;++i){if(array[i]){int cnt=1,temp=array[i];int posi=A[i].pos;if(array[posi]<temp)temp=array[posi];while(posi!=i){cnt++;posi=A[posi].pos;temp=min(temp,array[posi]);}ans+=min((cnt-2)*temp,(cnt+1)*minn+temp);array[i]=0;}}printf("%d\n",ans);}return 0;
}