题目传送门
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
题意:
给两个字符串,求LCS
分析:
- LCS模板题
- 水题
AC - Code:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<sstream>
#include<vector>
#include<stack>
#include<queue>
#include<cmath>
#include<map>
#include<set>
using namespace std;
typedef long long ll;
typedef pair<int,int> pll;
const int INF = 0x3f3f3f3f;
const int MAXN = 1000 + 5;string s1, s2;
int dp[MAXN][MAXN];
int dir[MAXN][MAXN];void Print(int i, int j){
if(i==0 && j==0)return;if(dir[i][j]==2){
Print(i-1, j);cout << s1[i-1];}else if(dir[i][j]==1){
Print(i-1, j-1);cout << s1[i-1];}else if(dir[i][j]==3){
Print(i, j-1);cout << s2[j-1];}}
int main(){
ios::sync_with_stdio(false);while(cin >> s1 >> s2){
memset(dp, 0, sizeof(dp));memset(dir, 0, sizeof(dir));for(int i = 0; i < s1.length(); i++)dir[i][0]=2;for(int i = 0; i < s2.length(); i++)dir[0][i]=3;for(int i = 1; i <= s1.length(); i++){
for(int j = 1; j <= s2.length(); j++){
if(s1[i-1] == s2[j-1]){
dp[i][j]=dp[i-1][j-1]+1;dir[i][j]=1;//左上方}else {
if(dp[i-1][j]>dp[i][j-1]){
dp[i][j]=dp[i-1][j];dir[i][j]=2;///来自于左方}else{
dp[i][j]=dp[i][j-1];dir[i][j]=3;///来自于上方}}}}//Print(s1.length(), s2.length());// cout << endl;cout << dp[s1.length()][s2.length()] << endl;}return 0;
}