题目传送门
Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.
A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.
A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.
Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.
For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:
AGTGAT-G
-GT–TAG
In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.
denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.
Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):
AGTGATG
-GTTA-G
This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
Output
The output should print the similarity of each test case, one per line.
Sample Input
2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
Sample Output
14
21
题意:
给定两组序列,要你求出它们的最大相似度,每个字母与其他字母或自身和空格对应都有一个打分,求在这两个字符串中插入空格,让这两个字符串的匹配分数最大
题解:
首先定义对X(xm) = {x1,x2,x3,…xm};Y(yn) = {y1,y2,y3,…yn};这两个按照题目的
要求得到最大值的排列M{…}所对应的最大值是f(m,n);
当xm != yn 时候
现在来思考一些结论:
-
1、最大排列M{…}一定是
P(xm,—):… xm … — 或者
P(_,yn):… — … yn 或者
P(xm,yn):… xm … yn 这样中的一种。因为xm,yn分别是X,Y的最后两个元素,在最大排列的上下两行中它们也必然是最后的"非—"元素.
-
2、如果最大值f(m,n)是以P(xm,—) 这样的形式的,那么我们可以看到这个时候的yn是在那串省略号里面的,也就是说那串省略号是这样两个集合
X(xm-1) ={x1,x2,x3,…xm-1};Y(yn) = {y1,y2,y3,…yn}
的一种按照题目要求的排列,现在我们称这两个集合的排列所得到的值是w(m-1,n)
同时定义 t(xm,—) 是 “xm与—” 相对应的值.
那么就有 f(m,n) = w(m-1,n)+t(xm,—)我们现在证明w(m-1,n)是X(xm-1),Y(yn)集合排列的最大值:f(m-1,n).
由于如果存在一个w’(m-1,n) > w(m-1,n)那么w’(m-1,n)+t(xm,—) > w(m-1,n)+t(xm,—) = f(m,n).
也就是说存在一个比f(m,n)更大的值,矛盾.所以w(m-1,n)是最大值f(m-1,n) -
3、同样可以证明如果最大值f(m,n)是以 P(—,yn) 这样的形式的,
那么前面省略号所得到的值 w(m,n-1) 也必然是最大值f(m,n-1) -
4、如果最大值是以 P(xm,yn) 结尾的,
那么可以知道前面省略号所得到的值 w(m-1,n-1) 也必然
是最大值 f(m-1,n-1).
从上面几个结论看过来,我们就可以知道当xm != yn时,
f(m,n)一定是 f(m-1,n)+t(xm,—) ,f(m,n-1)+t(yn,—) ,f(m-1,n-1)+t(xm,yn) 中的最大的一个.
当xm == yn 时候
这个时候很简单,肯定是
f(m,n) = f(m-1,n-1) + t(xm,yn);
综合上面所有的东西,我们就完成了为动态规划提供子结构的过程,剩下就是LCS的编写工作了.
不过,有点要提醒一下,就是初始的时候,比如f(m,0)或者f(0,n)它们不是很简单的置成0的,它们其中有一个不是空集,而是这样的 f(m,0) = f(m-1,0)+t(m,—) ; f(0,n) = f(0,n-1)+ t(—,n)
只有 f(0,0) = 0. 就是上下两个都是空集嘛.
AC-Code:
#include <iostream>
#include <vector>
#include <utility>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <queue>
#include <stack>
#include <cstdio>
#include <fstream>
#include <set>
#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
using namespace std;
typedef long long ll;const int INF = 0x3f3f3f;
const int MAXN = 1e4 + 100;int max(int a, int b, int c) {
int t = a > b ? a : b;return t > c ? t : c;
}
const int N = 105;
int dp[N][N]; //dp[i][j]:s1基因的前i个碱基和s2基因的前j个碱基中的最优匹配解
map<char, int>m;
int v[5][5] = {
{
5,-1,-2,-1,-3},
{
-1,5,-3,-2,-4},
{
-2,-3,5,-2,-2},
{
-1,-2,-2,5,-1},
{
-3,-4,-2,-1,-5}
};int main() {
m['A'] = 0, m['C'] = 1, m['G'] = 2, m['T'] = 3, m['-'] = 4;string a, b;int t, len, len2;cin >> t;while (t--){
cin >> len >> a >> len2 >> b;memset(dp, 0, sizeof(dp));//初始化 dp[i][0]表示字串s1前i個字串和長度為i的空格串匹配的值dp[0][0] = 0;for (int i = 1; i <= a.length(); i++)dp[i][0] = dp[i - 1][0] + v[m[a[i - 1]]][m['-']];for (int j = 1; j <= b.length(); j++)dp[0][j] = dp[0][j - 1] + v[m['-']][m[b[j - 1]]];for (int i = 1; i <= a.length(); i++)for (int j = 1; j <= b.length(); j++){
int temp = dp[i - 1][j - 1] + v[m[a[i - 1]]][m[b[j - 1]]];int temp2 = dp[i - 1][j] + v[m[a[i - 1]]][m['-']];int temp3 = dp[i][j - 1] + v[m['-']][m[b[j - 1]]];dp[i][j] = max(temp, max(temp2, temp3));}cout << dp[len][len2] << endl;}return 0;
}