当前位置: 代码迷 >> 综合 >> [PAT A1046]Shortest Distance
  详细解决方案

[PAT A1046]Shortest Distance

热度:76   发布时间:2023-12-15 06:27:34.0

[PAT A1046]Shortest Distance

题目描述

1046 Shortest Distance (20 分)The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10?5??]), followed by N integer distances D?1?? D?2??? D?N??, where D?i?? is the distance between the i-th and the (i+1)-st exits, and D?N?? is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10?4??), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10?7??.

输出格式

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例

5 1 2 4 14 9
3
1 3
2 5
4 1

输出样例

3
10
7

分析

  1. 题目翻译:最短距离,这个任务十分的简单,给你N个结点围成一个圈,你应该给出任意两个点之间的最短距离。
  2. 输入格式:首先是输入N[3,105],表示有N个点,然后输入D1,D2……DN,例如Di就表示第i个点到第i+1个点的距离,DN存放的是第N个点到第一个点的距离;
  3. 然后输入M[≤104],表示接下来有M组数据,对于每组数据要求它们之间的最短距离
  4. 算法分析:首先我是这样想的,把D1到DN都存放到数组里面,因为最短距离要么就是顺时针,要么就是逆时针(因为它们之间是不能跨过点的,比如求点1到点4的距离,要么就是点1到点2+点2到点3+点3到点4的距离,要么就是点4到点5+点5到点6+……+点N-1到点N+点N到点1的距离),我们就从小的点出发,累加到大的点,最后比较顺时针和逆时针的长度,得出结果。
这个结果拿了17分(满分20),最后一组数据是超时了,说明我们还有缺陷,这个时候要是时间不够的话我推荐先往后做,不要因为为了这3分导致后面的题目没有完成
#include<iostream>
using namespace std;
const int maxn = 100010;  //数组最大长度
int dis[maxn] = {
     0 }; //初始化
int main()
{
    int N, M, all_dis = 0;  //all_dis用于计算围成一圈的总长度cin >> N;for (int i = 1; i <= N; i++){
    cin >> dis[i];all_dis += dis[i];}cin >> M;while (M--){
    int a, b, dist = 0;   //dist用于存储点a到点b的长度cin >> a >> b;if (a < b) {
    while (a < b) dist += dis[a++];   //a<b就不断从a加到b为止}else{
    while (b < a) dist += dis[b++];   //同理,b<a就不断从b加到a为止}cout << ((dist < (all_dis - dist)) ? dist : (all_dis - dist)) << endl;//有可能顺时针短,有可能逆时针短,所以需要比较当前计算长度和总长度减去当前计算长度的大小}return 0;
}
好,接下来我们来说为什么会超时,因为我们最多最多有105个点,查询次数最多有104次,所以在极端情况下我们要做的操作有109次,所以我马上想到了使用数列和的概念,利用数列和的差得到中间一段数的和
#include<iostream>
using namespace std;
const int maxn = 100010;
int dis[maxn] = {
     0 };
int main()
{
    int N, M, all_dis = 0;cin >> N;for (int i = 1; i <= N; i++){
    cin >> dis[i];all_dis += dis[i];dis[i] = all_dis;}cin >> M;while (M--){
    int a, b, dist = 0;cin >> a >> b;if (a < b) dist = dis[b - 1] - dis[a - 1];else dist = dis[a - 1] - dis[b - 1];cout << ((dist < (all_dis - dist)) ? dist : (all_dis - dist)) << endl;}return 0;
}

水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位大牛提出宝贵的意见!

  相关解决方案