The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V?1 V2 … Vn
where n is the number of vertices in the list, and Vi’s are the vertices on a path.
Output Specification:
For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
题意:给出顶点和边的信息,判断是不是哈密尔顿图
在图中从起点开始走,走完所有的顶点回到起点,经过的点的次数都为一次,称为哈密尔顿路径。
思路:设置flag1判断节点有没有少走,没走到,或者没有走成环
设置flag2判断这条路能不能走得通
只有当flag1和flag都为1的时候才是哈密尔顿图
#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<cctype>
#include<cstdlib>
#include<ctime>
#include<unordered_map>using namespace std;int main() {
int n,m,k;int a[210][210] = {
0};scanf("%d%d",&n,&m);for(int i = 0;i < m;i++) {
int t1,t2;scanf("%d%d",&t1,&t2);a[t1][t2] = 1;a[t2][t1] = 1;} int num;scanf("%d",&num);for(int i = 0;i < num;i++) {
scanf("%d",&k);vector<int> v(k);set<int> s;int flag1 = 1;int flag2 = 1;for(int j = 0;j < k;j++) {
scanf("%d",&v[j]);s.insert(v[j]);}if(s.size() != n || k - 1 != n || v[0] != v[k - 1]) {
flag1 = 0;}for(int j = 0;j < k - 1;j++) {
if(a[v[j]][v[j + 1]] == 0) {
flag2 = 0;}}if(flag1 != 0 && flag2 != 0) {
printf("YES\n");} else {
printf("NO\n");}}return 0;
}