Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^?4?]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10^5) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
题意:输入n个数,输出第一个出现只出现一次的数字,如果没有这些数字,则输出None。
思路:先用vector存储输入的序列,然后再用hash数组来存储这些数字出现的次数,每次都从0循环到n-1即可。
#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>using namespace std;int n;
int hash1[10010];int main() {
scanf("%d",&n);vector<int> v(n);for(int i = 0;i < n;i++) {
scanf("%d",&v[i]);}for(int i = 0;i < n;i++) {
hash1[v[i]]++;}for(int i = 0;i < n;i++) {
if(hash1[v[i]] == 1) {
printf("%d\n",v[i]);return 0;}}printf("None\n");return 0;
}