当前位置: 代码迷 >> 综合 >> 1065 A+B and C (64bit) (20 分) 大整数比较
  详细解决方案

1065 A+B and C (64bit) (20 分) 大整数比较

热度:55   发布时间:2023-12-14 01:13:28.0

Given three integers A, B and C in [?2^?63,2 ^63], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题意:输入t组数据,每组数据中都有三个数,如果a+b大于c就输出true,反之输出false
思路:如果单纯只考虑a+b和c比较的话,一个测试点都会过不去,因为要考虑到数据溢出的问题。
因为A、B的大小为[-2^63, 2^63],?用long long 存储A和B的值,以及他们相加的值sum:
如果A > 0, B < 0 或者 A < 0, B > 0,sum是?可能溢出的
如果A > 0, B > 0,sum可能会溢出,sum范围理?应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2]是个负数,所以sum < 0时候说明溢出?
如果A < 0, B < 0,sum可能会溢出,同?,sum溢出后结果是大于0的,所以sum > 0 说明溢出?

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>using namespace std;int main() {
    long long int a,b,c,sum;int t;scanf("%d",&t);for(int i = 1;i <= t;i++) {
    scanf("%lld%lld%lld",&a,&b,&c);long long sum = a + b;if(a >= 0 && b >= 0 && sum < 0) {
    printf("Case #%d: true\n",i);} else if(a < 0 && b < 0 && sum >= 0) {
    printf("Case #%d: false\n",i);} else if(a + b > c) {
    printf("Case #%d: true\n",i);} else {
    printf("Case #%d: false\n",i);}}return 0;
}
  相关解决方案