当前位置: 代码迷 >> 综合 >> PAT 1008 数组元素循环右移问题 (20分)
  详细解决方案

PAT 1008 数组元素循环右移问题 (20分)

热度:39   发布时间:2023-12-12 11:04:54.0

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A0?? A????N?1)变换为(A?N?M?A?N?1A?0 A?1?? ?A?N?M?1?? )(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:
每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。

输出格式:
在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:
6 2
1 2 3 4 5 6

输出样例:
5 6 1 2 3 4

#include <iostream>
using namespace std;
void Rshiftx(int *a,int from,int to) //1 2 3 4 5
{
    int tem;for(int i=0;i<=(to-from)/2;i++)//5-3/2{
    tem = *(a+from+i) ;*(a+from+i) = *(a+to-i);*(a+to-i)   = tem ;#if 0 //不知道为什么·,用指指针实现这种交换会出错*(a+from+i) = *(a+from+i) + *(a+to-i);*(a+to-i)   = *(a+from+i) - *(a+to-i);*(a+from+i) = *(a+from+i) - *(a+to-i);#endif}
}
int main()
{
    int n,m;int flag = 0;int *p = NULL;cin >>n>>m;int arr[n];p = arr;for(int i=0;i<n;i++){
    cin >> arr[i];}if(m==0||(m%n==0));else{
    m = m%n;Rshiftx(arr,0,n-1);Rshiftx(arr,0,m-1);Rshiftx(arr,m,n-1);}for(int i=0;i<n;i++){
    if(flag == 1) cout<<" ";cout<<*(p+i);flag =1;}return 0;
}