当前位置: 代码迷 >> 综合 >> java sdut-sel-2 汽车超速罚款(选择结构)
  详细解决方案

java sdut-sel-2 汽车超速罚款(选择结构)

热度:106   发布时间:2023-11-29 14:12:47.0

1.题目详情

许多社区都有“雷达”标志,告诉司机他们的速度是多少,希望他们能够慢下来。
你将输出一个“雷达”标志的信息,根据司机驾驶车速的情况向他(她)显示信息。

11.jpg

2.输入格式:

在一行内输入2个整数。第一个表示速度的限制,第二个表示司机的开车速度。

3.输出格式:

如果司机没有超速,输出应该是:Congratulations, you are within the speed limit!
如果司机超速行驶,输出为:You are speeding and your fine is F.(F为上表中描述的罚款数额)

输入样例1:

40 39

结尾无空行

输出样例1:

Congratulations, you are within the speed limit!

结尾无空行

输入样例2:

100 131

结尾无空行

输出样例2:

You are speeding and your fine is 500.

结尾无空行

输入样例3:

100 120

结尾无空行

输出样例3:

You are speeding and your fine is 100.

结尾无空行

 4.代码详情

import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int speedLimit,speed,fine;
speedLimit=sc.nextInt();
speed=sc.nextInt();if(speed<=speedLimit)
System.out.println("Congratulations, you are within the speed limit!");
else if(speed-speedLimit>=1 && speed-speedLimit<=20)
System.out.println("You are speeding and your fine is 100.");
else if(speed-speedLimit>=21 && speed-speedLimit<=30)
System.out.println("You are speeding and your fine is 270.");
else
System.out.println("You are speeding and your fine is 500.");
}
}

5.输入案例运行

 6.提交结果

 

  相关解决方案