数据结构实验之链表三:链表的逆置
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Example Input
12 56 4 6 55 15 33 62 -1
Example Output
62 33 15 55 6 4 56 12
Hint
不得使用数组。
Author
感悟:这道题需要考虑指针p的使用,以及输入的变量a,a的值赋予。。。。即可解决
**
#include <stdio.h>
#include <stdlib.h>
struct node
{int data;struct node * next;
};
struct node *f1(int n)
{int i;struct node *head,*p,*t;head =(struct node *)malloc (sizeof(struct node));head->next =NULL;t=head;for(i=0; i<n; i++){p=(struct node *)malloc(sizeof(struct node));scanf("%d ",&p->data);p->next =NULL;t ->next = p;t=p;}return head;
}
struct node * f2(struct node *head1,struct node *head2)
{struct node * p1,*p2,*t;p1=head1->next;p2=head2->next;head1->next=NULL;t=head1;head2->next=NULL;free(head2);while(p1&&p2){if(p1->data<p2->data){t->next =p1;t=p1;p1=p1->next;}else //if(p1->data>=p2->data)为什么这么做不对{t->next =p2;t=p2;p2=p2->next;}if(p1)t->next=p1;elset->next=p2;}return head1;
}
int main()
{int a;struct node *head,*p,*q;head =(struct node *)malloc (sizeof(struct node));head->next =NULL;while(scanf("%d ",&a)!=EOF){if(a==-1)break;else{p=(struct node *)malloc(sizeof(struct node));p->data=a;p->next =head->next;head->next=p;}}q=head->next;while(q){if(q->next!=NULL)printf("%d ",q->data);elseprintf("%d\n",q->data);q=q->next;}return 0;
}
**