1135. 新年好
重庆城里有 n 个车站,m 条 双向 公路连接其中的某些车站。
每两个车站最多用一条公路连接,从任何一个车站出发都可以经过一条或者多条公路到达其他车站,但不同的路径需要花费的时间可能不同。
在一条路径上花费的时间等于路径上所有公路需要的时间之和。
佳佳的家在车站 1,他有五个亲戚,分别住在车站 a,b,c,d,e。
过年了,他需要从自己的家出发,拜访每个亲戚(顺序任意),给他们送去节日的祝福。
怎样走,才需要最少的时间?
输入格式
第一行:包含两个整数 n,m,分别表示车站数目和公路数目。
第二行:包含五个整数 a,b,c,d,e,分别表示五个亲戚所在车站编号。
以下 m 行,每行三个整数 x,y,t,表示公路连接的两个车站编号和时间。
输出格式
输出仅一行,包含一个整数 T,表示最少的总时间。
数据范围
1≤n≤50000,
1≤m≤105,
1<a,b,c,d,e≤n,
1≤x,y≤n,
1≤t≤100
输入样例:
6 6
2 3 4 5 6
1 2 8
2 3 3
3 4 4
4 5 5
5 6 2
1 6 7
输出样例:
21
#include <bits/stdc++.h>
#define x first
#define y second
using namespace std;
const int N = 50010, M = 2e5 + 10;
const int INF = 0x3f3f3f3f;
typedef pair<int, int>PII;
int n, m;
int source[6];//存亲戚,0存自己
bool st[N];
int dist[6][N];//每一维存的是该点到每个点的最短距离
int h[N], ne[M], e[M], w[M], idx;
void add(int a, int b, int c)//创建邻接表
{
e[idx] = b;w[idx] = c;ne[idx] = h[a];h[a] = idx++;
}
//堆优化dijkstra
void dijkstra(int start, int dist[])//这里dist[]是一维
{
memset(dist, 0x3f, 4 * N);memset(st, 0, sizeof st);priority_queue<PII, vector<PII>, greater<PII>>heap;heap.push({
0,start });dist[start] = 0;while (heap.size()){
auto t = heap.top();heap.pop();int ver = t.y;int distance = t.x;if (st[ver])continue;st[ver] = true;for (int i = h[ver]; ~i; i = ne[i]){
int j = e[i];if (dist[j] > dist[ver] + w[i]){
dist[j] = dist[ver] + w[i];heap.push({
dist[j],j });}}}
}
int dfs(int u,int start,int distance)
{
if (u == 6)return distance;int res = INF;for (int i = 1; i <= 5; i++){
if (!st[i]){
int next = source[i];st[i] = true;res = min(res, dfs(u + 1, i, dist[start][next] + distance));st[i] = false;}}return res;
}
int main()
{
cin >> n >> m;memset(h, -1, sizeof h);source[0] = 1;for (int i = 1; i <= 5; i++)cin >> source[i];while (m--){
int x, y, t;cin >> x >> y >> t;add(x, y, t);add(y, x, t);}for (int i = 0; i < 6; i++)dijkstra(source[i], dist[i]);memset(st, 0, sizeof st);cout << dfs(1, 0, 0) << endl;return 0;
}
167. 木棒
乔治拿来一组等长的木棒,将它们随机地砍断,使得每一节木棍的长度都不超过 50 个长度单位。
然后他又想把这些木棍恢复到为裁截前的状态,但忘记了初始时有多少木棒以及木棒的初始长度。
请你设计一个程序,帮助乔治计算木棒的可能最小长度。
每一节木棍的长度都用大于零的整数表示。
输入格式
输入包含多组数据,每组数据包括两行。
第一行是一个不超过 64 的整数,表示砍断之后共有多少节木棍。
第二行是截断以后,所得到的各节木棍的长度。
在最后一组数据之后,是一个零。
输出格式
为每组数据,分别输出原始木棒的可能最小长度,每组数据占一行。
数据范围
数据保证每一节木棍的长度均不大于 50。
输入样例:
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
输出样例:
6
5
#include <bits/stdc++.h>
using namespace std;
const int N = 70;
int n;
int w[N];
int sum, length;
bool st[N];
bool dfs(int u, int cur, int start)//使用的木棍个数,当前拼凑的长度和,开始枚举的位置
{
if (u * length == sum)return true;if (cur == length)return dfs(u + 1, 0, 0);for (int i = start; i < n; i++){
if (st[i] || cur + w[i] > length)continue;st[i] = true;if (dfs(u, cur + w[i], i + 1))return true;st[i] = false;if (!cur || cur + w[i] == length)return false;//剪枝,如果当前木棍是空的,直接回溯。如果提前凑成需要的length,则直接回溯int j = i;while (j < n && w[j] == w[i])j++;//剪枝,避免重复i = j - 1;}return false;
}
int main()
{
while (cin >> n, n){
memset(st, 0, sizeof st);sum = 0;for (int i = 0; i < n; i++){
cin >> w[i];sum += w[i];}sort(w, w + n);reverse(w, w + n);//剪枝,优化搜索顺序。从大到小排序,因为大的木棍决策少length = 1;//从长度1开始分别枚举while (1){
if (sum % length == 0&&dfs(0,0,0)){
cout << length << endl;break;}length++;}}return 0;
}
1140. 最短网络
农夫约翰被选为他们镇的镇长!
他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。
约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。
约翰的农场的编号是1,其他农场的编号是 2?n。
为了使花费最少,他希望用于连接所有的农场的光纤总长度尽可能短。
你将得到一份各农场之间连接距离的列表,你必须找出能连接所有农场并使所用光纤最短的方案。
输入格式
第一行包含一个整数 n,表示农场个数。
接下来 n 行,每行包含 n 个整数,输入一个对角线上全是0的对称矩阵。
其中第 x+1 行 y 列的整数表示连接农场 x 和农场 y 所需要的光纤长度。
输出格式
输出一个整数,表示所需的最小光纤长度。
数据范围
3≤n≤100
每两个农场间的距离均是非负整数且不超过100000。
输入样例:
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
输出样例:
28
#include <bits/stdc++.h>
using namespace std;
const int N = 110;
int n;
int w[N][N];
int dist[N];
bool st[N];
int prim()
{
int res = 0;memset(dist, 0x3f, sizeof dist);dist[1] = 0;for (int i = 0; i < n; i++){
int t = -1;for (int j = 1; j <= n; j++){
if (!st[j] && (t == -1 || dist[t] > dist[j]))t = j;}res += dist[t];st[t] = true;for (int j = 1; j <= n; j++){
dist[j] = min(dist[j], w[t][j]);}}return res;
}
int main()
{
cin >> n;for (int i = 1; i <= n; i++)for (int j = 1; j <= n; j++)cin >> w[i][j];cout << prim() << endl;return 0;
}