题目描述
题的目标很简单,就是求两个正整数A和B的和,其中A和B都在区间[1,1000]。稍微有点麻烦的是,输入并不保证是两个正整数。
输入格式:
输入在一行给出A和B,其间以空格分开。问题是A和B不一定是满足要求的正整数,有时候可能是超出范围的数字、负数、带小数点的实数、甚至是一堆乱码。
注意:我们把输入中出现的第1个空格认为是A和B的分隔。题目保证至少存在一个空格,并且B不是一个空字符串。
输出格式:
如果输入的确是两个正整数,则按格式A + B = 和输出。如果某个输入不合要求,则在相应位置输出?,显然此时和也是?。
输入样例1:
123 456
输出样例1:
123 + 456 = 579
输入样例2:
- 18
输出样例2:
? + 18 = ?
输入样例3:
-100 blabla bla…33
输出样例3:
? + ? = ?
笔记
string的getline
string a, b;getline(cin, a,' ');getline(cin, b);
stoi 字符串转换为数字形式
if (stoi(a) < 1 || stoi(a) > 1000)shua = false;
isdigit 判断是否为数字
if (!isdigit(a[i]))shua = false;
实现代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
string a, b;getline(cin, a,' ');bool shua = true, shub = true;for (int i = 0; i < a.length(); i++){
if (!isdigit(a[i]))shua = false;}if (shua) {
if (stoi(a) < 1 || stoi(a) > 1000)shua = false;}getline(cin, b);for (int i = 0; i < b.length(); i++){
if (!isdigit(b[i]))shub = false;}if (shub) {
if (stoi(b) < 1 || stoi(b) > 1000)shub = false;}if (shua)cout << a << " + "; else cout << "?" << " + ";if (shub)cout << b << " = "; else cout << "?" << " = ";if (shua && shub)cout << stoi(a) + stoi(b);else cout << "?";return 0;
}