PAT (Basic Level) Practice 1081 检查密码 (15 分)
题目
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点.
,还必须既有字母也有数字。
输入格式
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
注意: 题目保证不存在只有小数点的输入。
输出格式
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
- 如果密码合法,输出
Your password is wan mei.
; - 如果密码太短,不论合法与否,都输出
Your password is tai duan le.
; - 如果密码长度合法,但存在不合法字符,则输出
Your password is tai luan le.
; - 如果密码长度合法,但只有字母没有数字,则输出
Your password needs shu zi.
; - 如果密码长度合法,但只有数字没有字母,则输出
Your password needs zi mu.
。
输入样例
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
题解
一道比较简单的字符串习题
- 判断字母数字可以使用库函数
isdigit(int c)
和isalpha(int c)
, 头文件#include<cctype>
- 由于存在着几种情况,可以使用二进制的每一位代表一种情况,使用按位或来更新情况,用按位与来判断情况
- 传入引用减少复制的时间
AC Code
#include<iostream>
#include<string>
#include<cctype>
using namespace std;int check(string& s){
if(s.length()<6) return 1; //too shortint flag = 0;//二进制 第1位代表数字 第2位代表字母 第三位代表点 第四位代表其他字符for(auto & c:s){
if(isdigit(c)) flag|=1;else if(isalpha(c)) flag|=2;else if(c=='.') flag|=4;else flag|=8;}if(flag&8) return 2; //other characterif((flag&2) == 0) return 4; //no alphaif((flag&1) == 0) return 3; //no digitreturn 0;
}int main(){
int n;cin >> n;getchar(); //接收换行符while(n--){
string s;getline(cin,s);switch(check(s)){
case 0: cout << "Your password is wan mei." <<endl; break;case 1: cout << "Your password is tai duan le." <<endl; break;case 2: cout << "Your password is tai luan le." <<endl; break;case 3: cout << "Your password needs shu zi." <<endl; break;case 4: cout << "Your password needs zi mu." <<endl; break;}}
}