PAT (Advanced Level) Practice 1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
- Itai nyan~ (It hurts, nyan~)
- Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
思路
- 找到最长的公共后缀
reverse
之后找最长公共前缀- 先求第一个字符串和第二个字符串的公共后缀, 再用这个后缀和第三个字符串求公共后缀… 直到和最后一个字符串求完公共后缀
AC code
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;int main(){
int N;string ans;cin>> N;getchar(); //接收换行符getline(cin,ans);reverse(ans.begin(),ans.end());for(int i=1;i<N;i++){
string s;getline(cin,s);reverse(s.begin(),s.end());int len = min(s.length(),ans.length());for(int j=0;j<len;j++){
if(ans[j]!=s[j]){
ans = ans.substr(0,j); break;}}}if(ans.empty()){
cout<<"nai";}else{
reverse(ans.begin(),ans.end());cout<<ans;}return 0;
}