spfa 判断负环 cnt [ j ] = cnt [ t ] + 1 ,若当前点的最短路所包含的边数大于等于点数 n ,则说明该路径上存在负环,写法和 spfa 求最短路相同,只需要加一个 cnt [ ] 数组记录每个点的最短路的边数即可,在初始化队列的时候,需要将所有的点都放入到队列中,因为需要判断所有点的最短路上是否存在负环
需要从每个点都出发一次,才能完全确定此图中是否有环
cnt[j]=n
编号编号为j
的节点是第n
个加入路径的节点,
负环:环路之和为负, 求最短路的时候会不断在负环路打转。
bool spfa()
{
memset(dist,0x3f,sizeof dist);queue<int> q;for(int i=1;i<=n;i++){
q.push(i);st[i]=true;}dist[1]=0;while(q.size()){
int t=q.front();q.pop();st[t]=false;for(int i=h[t];i!=-1;i=ne[i]){
int j=e[i];if(dist[j]>dist[t]+w[i]){
dist[j]=dist[t]+w[i];cnt[j]=cnt[t]+1;// cnt[j]++;if(!st[j]){
q.push(j);st[j]=true;}if(cnt[j]>=n) return true;}}}return false;
}
题目链接
给定一个 n 个点 m 条边的有向图,图中可能存在重边和自环, 边权可能为负数。
请你判断图中是否存在负权回路。
输入格式
第一行包含整数 n 和 m。
接下来 m 行每行包含三个整数 x,y,z,表示存在一条从点 x 到点 y 的有向边,边长为 z。
输出格式
如果图中存在负权回路,则输出 Yes,否则输出 No。
数据范围
1≤n≤2000,
1≤m≤10000,
图中涉及边长绝对值均不超过 10000。
输入样例:
3 3
1 2 -1
2 3 4
3 1 -4
输出样例:
Yes
spfa 判断负环和 spfa 求最短路基本相同,新增一个 cnt 数组,若存在负环,在负环出一定会循环多次最终超过 n ,因此判断 cnt 数组是否超过 n 就可以判断是否存在负环。
代码样例
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<sstream>
#include<map>#define x first
#define y secondusing namespace std;
typedef long long ll;
typedef pair<int, int> PII;
const int N = 100010;
const int MOD = 1000000007;
const int INF = 0x3f3f3f3f;int gcd(int a, int b){
return b ? gcd(b, a % b) : a;}
int lowbit(int x) {
return x & -x;}int n, m;
int h[N], e[N], ne[N], w[N], idx;
queue<int> q;
int dist[N], cnt[N];
bool st[N];void add(int a, int b, int c)
{
e[idx] = b;ne[idx] = h[a];w[idx] = c;h[a] = idx ++ ;
}bool spfa()
{
memset(dist, 0x3f, sizeof dist);for(int i = 1; i <= n; i ++ ){
q.push(i);st[i] = true;}while(q.size()){
int t = q.front();q.pop();st[t] = false;for(int i = h[t]; i != -1; i = ne[i]){
int j = e[i];if(dist[j] > dist[t] + w[i]){
dist[j] = dist[t] + w[i];cnt[j] = cnt[t] + 1;if(cnt[j] >= n) return true;if(!st[j]){
st[j] = true;q.push(j);}}}}return false;}int main()
{
cin >> n >> m;memset(h, -1, sizeof h);for(int i = 0; i < m; i ++ ){
int a, b, c;cin >> a >> b >> c;add(a, b, c);}if(spfa()) cout << "Yes" << endl;else cout << "No" << endl;return 0;
}