当前位置: 代码迷 >> 综合 >> Characters with Hash
  详细解决方案

Characters with Hash

热度:36   发布时间:2023-11-22 14:02:36.0

题目链接
Mur loves hash algorithm, and he sometimes encrypt another one’s name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256 , which can transit a string into just 256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string s, s[i] represents the ith character in the string) we calculates the value(|(int) L - s[i]|), and write down the number(keeping leading zero. The length of each answer equals to 2 because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(s)). For instance, if we choose 'z' as the seed, the string “oMl” becomes “11 45 14”.

It’s easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer T , the number of test cases (T≤10).

For each test case:

First line contains a integer N and a character z(N≤1000000).

Second line contains a string with length N . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入

2
3 z
oMl
6 Y
YJSNPI

样例输出

6
10

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

几个函数的讲解:

s = "12";
s.resize(5,'0');
结果:12000 而不是:00012
s = "12";
to_string(s);
s就变成字符串了
#include<bits/stdc++.h>
using namespace std;
int main(){
    char c;int t,n,k;string s,tmp,x;cin >> t;for(auto i = 0;i < t;i++){
    tmp.clear();cin >> n >> c >> s;for(auto j = 0;j < s.size();j++){
    x = to_string(abs(s[j] - c));x.resize(2,'0');//补的是后置零,而不是前置零!!!reverse(x.begin(),x.end());//反转下即可tmp += x;}for(k = 0;tmp[k] == '0' && k < tmp.size();k++);if(k >= tmp.size()){
    //如果全部是零的话,答案是1cout << 1 << endl;}else{
    cout << tmp.size() - k << endl;}}return 0;
}
  相关解决方案